Contrôler sa VMC StorkAir / ComfoAir / zehnder via sa domotique

( dans

» Electricité » Domotique

)
Chercher:    

Contrôler sa VMC StorkAir / ComfoAir / zehnder via sa domotique

- Page 55
Page 55 sur 67 Première page - Résultats 1 à 20 sur 1 340 Page precedente 5455354 55 565765 Page suivante Dernière page - Résultats 1 321 à 1 340 sur 1 340


01/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
The setup of each raspberry is bound to be different, eg. our apache is running on port 8080 which is not the case for everyone, you run motion and presumably other programs, the VMC setup is also characteristics as your USB-Serial might not be the same of another installation. That is what I mean. We cannot assume that only the raspVMC setup is important.

Yes you can use the server service file and adapt it to the socat CCEASE process
01/02/2016 Vieux  
 
  Autre pays
 
Ok, I will test secondary RS232 port and let you know...
But even on pure Wheezy (no motion, Apache on default settings, no other programs installed) everything is the same as on Jessie. Therefore, VMC unit is to be blamed

EDIT:
I wanted to test system with socat command executed:
Citation:
socat /dev/ttyUSB0,b9600,raw,echo=0 tcp:localhost:10001
And after more or less half an hour, VMC went out of control:
- percentage setpoint remained at 35% (speed 2, on display visible as 1)
- but revs went sky high, up to 2900 rpm (100%)

I couldn't do anything but unplug the power - controls didn't work. It seems like there was a comms mess between CCEase and raspbpi. Now I believe more that my hardware is slightly different...

Dernière modification par listhor 01/02/2016 à 23h06. Motif: VMC control

02/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
Citation:
Posté par listhor Voir le message
Ok, I will test secondary RS232 port and let you know...
But even on pure Wheezy (no motion, Apache on default settings, no other programs installed) everything is the same as on Jessie. Therefore, VMC unit is to be blamed

EDIT:
I wanted to test system with socat command executed:

And after more or less half an hour, VMC went out of control:
- percentage setpoint remained at 35% (speed 2, on display visible as 1)
- but revs went sky high, up to 2900 rpm (100%)

I couldn't do anything but unplug the power - controls didn't work. It seems like there was a comms mess between CCEase and raspbpi. Now I believe more that my hardware is slightly different...
That's indeed rather strange, I had a few occasion of lock up of the main unit, but never a change in the revs of the fans to the max. As you say the firmware might be different, there is no way we could know for sure.
02/02/2016 Vieux  
  34 ans, France
 
Bon me revoila.
Je dois encore avoir un souci sur la couche physique ...

Quelque soit le cablage TX RX avec TX RX ou RX TX avec TX RX (le bon celui la) j'ai les memes logs...
Citation:
02/02/16 20:47:43 : closing ('127.0.0.1', 53304) after reading no data
02/02/16 20:47:43 : new client connection from ('127.0.0.1', 53313)
02/02/16 20:47:43 : received 07f0000b00b8070f ('127.0.0.1', 53313) from client ('127.0.0.1', 53313) retained is 07f0000b00b8070f
02/02/16 20:47:43 : Processing msg from queue ('127.0.0.1', 53313)
02/02/16 20:47:43 : Sending frame 07f0000b00b8070f to VMC from Client ('127.0.0.1', 53313)
02/02/16 20:47:43 : Command code: 0b reply is True
02/02/16 20:47:43 : expecting a reply
02/02/16 20:47:43 : received from VMC 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000
02/02/16 20:47:43 : No frame detected in 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 000000000000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000
Du coup je teste l'astuce en écartant la VMC et en reliant direct la patte 2 et 3 de mon adaptateur (patte GND en l'air) et meme résultat:
Citation:
02/02/16 20:51:20 : received from VMC 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000
02/02/16 20:51:20 : No frame detected in 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 000000000000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000
Autre question:

Pourquoi dans un navigateur web l'@ @IP Rasp:10001 ne renvoit rien.
Idem avec IP Rasp/canevas.html

Merci à vous
02/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
Citation:
Posté par rjcab Voir le message
Bon me revoila.
Je dois encore avoir un souci sur la couche physique ...

Quelque soit le cablage TX RX avec TX RX ou RX TX avec TX RX (le bon celui la) j'ai les memes logs...
Du coup je teste l'astuce en écartant la VMC et en reliant direct la patte 2 et 3 de mon adaptateur (patte GND en l'air) et meme résultat:
Autre question:

Pourquoi dans un navigateur web l'@ @IP Rasp:10001 ne renvoit rien.
Idem avec IP Rasp/canevas.html

Merci à vous
OK déjà maintes fois vu, problème de câblage, est tu certains que tu connectes 2 et 3 et pas 3 et 4 un utilisateur m'a rapporté que sont convertisseur USB/série Made in China avait les pins inversées (1 sur 5, 2 sur 4, 3 sur 3, 4 sur 2 et 5 sur 1).

Normalement sir 2 et 3 sont court circuitées sur le convertisseur les trames sortantes (en provenance du client) reviennent et sont indiquées dans le log, or tu as des niveaux 0 (qui parfois est symptomatique d'une masse flottante, mais en court circuitant 2 et 3 la masse n'est pas flottante).

Le serveur est connecté sur le port 10001 dans ton cas, et sur cette connexion circulent des messages en hexadécimal qui sont au format du protocole de la VMC, ce port n'est pas destiné a être connecté par un navigateur Web (protocole html/ascii).

canvas.html ???

VMC3.html apelle un script cgi qui lui même appelle le port 10001 avec les trames ad hoc, si pas de réponse alors il n'y a rien a afficher.

Dernière modification par jcoenen 03/02/2016 à 00h01.
03/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
Tiens tiens, j'ai raté la sortie de celui-ci (SPECS)

A première vue on pourrait le mettre dans l'unité de VMC, comme il n'y a pas d'ethernet il faudrait prévoir un dongle USB (ehternet ou Wifi) et le convertisseur série sur le GPIO.

Ce serait assez sympa non ?
03/02/2016 Vieux  
  34 ans, France
 
Hello Jcoenen,

Bon alors je ne comprends pas, cela ne marche plus coté client serveur. Dans le doute je change le port, reboot le raspberry mais tjs la meme erreur:

Citation:
root@jeedom:~# cd raspVMC-master/
root@jeedom:~/raspVMC-master# ./client3.py
connecting to 127.0.0.1 port 11000
Traceback (most recent call last):
File "./client3.py", line 28, in <module>
sock.connect(server_address)
File "/usr/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
socket.error: [Errno 111] Connection refused
root@jeedom:~/raspVMC-master# ps -ef | grep server.py
root 1784 1159 0 20:48 pts/0 00:00:00 grep server.py
root@jeedom:~/raspVMC-master#
Coté cablage j'ai vérifié et bien idnetifié le RX et TX que je relie ensemble au niveau de l'adaptateur.
QUestion, je laisse bien le VCC et GND patte en l'air ? (potentiel entre les 2 DC 5V)

Merci
03/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
OK, bon comme l'installation n'est pas faite dans le bon directory (/home/pi/raspVMC-master mais /root/raspVMC-master) le path dans le fichier de lancement système n'est évidemment pas le bon ... maintenant j'ai rectifié la chose et le serveur démarre avec systemctl. J'en ai profité pour remettre les port 10001 10002 et 10003 vu que tu as webmin activé.

Concernant le RX broché avec le TX, maintenant c'est bon, voici un log de client ou les trames envoyées par le client reviennent par la boucle. Donc tout va bien de ce côté, reste plus qu'a câbler sur la VMC RX, TX et GND et faire le test final.

03/02/16 22:53:25 : new client connection from ('127.0.0.1', 42625)
03/02/16 22:53:25 : received 07f000690016070f ('127.0.0.1', 42625) from client ('127.0.0.1', 42625) retained is 07f000690016070f
03/02/16 22:53:25 : Processing msg from queue ('127.0.0.1', 42625)
03/02/16 22:53:25 : Sending frame 07f000690016070f to VMC from Client ('127.0.0.1', 42625)
03/02/16 22:53:25 : Command code: 69 reply is True
03/02/16 22:53:25 : expecting a reply
03/02/16 22:53:25 : received from VMC 07f000690016070f
03/02/16 22:53:25 : 8 frames received from VMC only one is expected from theread
03/02/16 22:53:25 : frame received from VMC stored in client queue 07f000690016070f
03/02/16 22:53:25 : sending 07f000690016070f to ('127.0.0.1', 42625)
03/02/16 22:53:25 : closing ('127.0.0.1', 42625) after reading no data
04/02/2016 Vieux  
  France
 
Citation:
Posté par jcoenen Voir le message
Tiens tiens, j'ai raté la sortie de celui-ci (SPECS)

A première vue on pourrait le mettre dans l'unité de VMC, comme il n'y a pas d'ethernet il faudrait prévoir un dongle USB (ehternet ou Wifi) et le convertisseur série sur le GPIO.

Ce serait assez sympa non ?
Oui j'avais vu, mais j'ai déjà quelques raspberry à utiliser et dans la boite luxe elles passent.
04/02/2016 Vieux  
 
  31 ans, Namur
 
Citation:
Posté par jcoenen Voir le message
Tout est dit ...

Sur une luxe il suffit de se brancher sur le port du Comofsense/CCease à la place du CCEASE.

Le CCEASE se branche alors sur un deuxième interface USB/RS232 sur le raspberry Pi ou sur un autre avec une alimentation 12 Volt.
Bonjour,

Désolé si la réponse se trouve quelque part dans cet abysmal post, j'ai parcouru rapidement.

le temps libre refait peu à peu son apparition, je reviens doc à ce post... J'ai une CC Ease que je souhaite garder fonctionnelle. Si j'ai bien compris il faut donc utiliser l'option "raspberry pi au milieu + socat".

J'ai lu ici que la VMC aurait également un port RS485, qui je suppose pourrait alors fonctionner en même temps que le RS232 du CC Ease. Je compte utiliser du RS485 pour interfacer ma PAC (Nibe) et mes onduleurs (PowerOne), le tout revenant à OpenHab (je n'ai pas encore essayé FHem), donc ce serait relativement cohérent pour moi

Quelqu'un peut confirmer/infirmer? Ca vous semble intéressant?
04/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
Citation:
Posté par blorent Voir le message
Bonjour,

Désolé si la réponse se trouve quelque part dans cet abysmal post, j'ai parcouru rapidement.

le temps libre refait peu à peu son apparition, je reviens doc à ce post... J'ai une CC Ease que je souhaite garder fonctionnelle. Si j'ai bien compris il faut donc utiliser l'option "raspberry pi au milieu + socat".

J'ai lu ici que la VMC aurait également un port RS485, qui je suppose pourrait alors fonctionner en même temps que le RS232 du CC Ease. Je compte utiliser du RS485 pour interfacer ma PAC (Nibe) et mes onduleurs (PowerOne), le tout revenant à OpenHab (je n'ai pas encore essayé FHem), donc ce serait relativement cohérent pour moi

Quelqu'un peut confirmer/infirmer? Ca vous semble intéressant?
Il faudrait voir le comportement des deux ports ensemble, il n'est pas certain que la VMC puisse être pilotée par deux devices simultanément même s'il sont sur des interface différents.

CCEASE et RaspVMC, oui il faut brancher le CCease sur un raspberry Pi et utiliser socat pour relayer les messages vers le serveur.

Si le RS485 permet du multipoint, le protocole de la VMC tel que je le connais ne supporte pas cette topologie (mais je ne sais pas tout non plus...)
04/02/2016 Vieux  
  34 ans, France
 
Hello ,

Alors cablage VMC réalisé.
Par contre en sortie de mon adaptateur je suis en 0 +5V.
Je me demandais si la VMC ne voulait pas plutot du 0 +12V ?

Citation:
Le RS232 réfère au signal qui circule sur le câble, c'est à dire des Niveaux de +/- 12 Volts sur 3 fils (TX-RX et signal ground).
Citation:
04/02/16 19:32:44 : closing ('127.0.0.1', 40246) after reading no data
04/02/16 19:32:46 : new client connection from ('127.0.0.1', 40256)
04/02/16 19:32:46 : received 07f0000b00b8070f ('127.0.0.1', 40256) from client ('127.0.0.1', 40256) retained is 07f0000b00b8070f
04/02/16 19:32:46 : Processing msg from queue ('127.0.0.1', 40256)
04/02/16 19:32:46 : Sending frame 07f0000b00b8070f to VMC from Client ('127.0.0.1', 40256)
04/02/16 19:32:46 : Command code: 0b reply is True
04/02/16 19:32:46 : expecting a reply
04/02/16 19:32:46 : received from VMC 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 000000000000000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000
04/02/16 19:32:46 : No frame detected in 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 000000000000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 00000000000000000000000000000000000000000000000000 0000000000000000000000000
00000000000000000000000000000
Sinon je n'ai pas compris comment vous arrivez a avoir une page web avec les datas de la VMC (temps, vitesse, ;..)

Merci
05/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
On obtient la page quand le message de la VMC est bien reçu, ce qui n'est pas le cas, tu ne reçois pas de signal sur le RX, ton convertisseur est en TTL pas en RS232 (0-5 Volts et pas +/- 12 Volts). As tu les références de cet appareil (marque/type) ?

La solution mettre un convertisseur qui est à la norme rs232 ou mettre un MAX232 qui va convertir les niveaux.

RS232
Électrique

Un niveau logique "0" est représenté par une tension de +3V à +25V et un niveau logique "1" par une tension de -3V à -25V (codage NRZ). D'ordinaire, des niveaux de +12V et -12V sont utilisés.
La norme V.28 indique qu'un 1 est reconnu si la tension est inférieure à -3 V, et un 0 est reconnu si la tension est supérieure à +3 V.
si ton interface fonctionne en 0-5 volts, il ne peut interpreter le signal RS232

Dernière modification par jcoenen 05/02/2016 à 01h03.
08/02/2016 Vieux  
 
  31 ans, Namur
 
Petit retour d'expérience avec un setup un peu différent du votre (de nouveau j'ai pas lu les 55 pages du post, désolé si il y a déjà eu des retours sur un setup similaire)

J'ai commencé à déployer un superviseur OpenHAB sur mon RPI (qui sera bientôt remplacé apr un serveur un peu plus costaud, mais ça ne changera rien au soft), OpenHAB ayant l'avantgae de supporter facilement tout ce dont j'ai besoin (il y a des bindings pour KNX, ma PAC, ma VMC et mes PV, c'est parfait)

Setup réglé en 3 minutes : pas touché à la connection de la CCEase, juste branché un cable USB -> série sur le port série de la VMC (ComfoD 450 Luxe). Instantanément reconnue par OpenHAB, juste eu à configurer les items et le sitemap et c'était parti.

En ce qui concerne l'intégration superviseur / CCEase il y a dans le module un switch de prévu pour donner la main soit à la CCEase (auquel cas celle-ci fonctionne et toutes les requests faites via le superviseur sont ignorées), soit au superviseur (auquel cas la CCEase est tout simplement éteinte - la connection est donc coupée directement au niveau de la VMC). Ca me semble plus simple que de chipoter avec socat, et ça marche bien pour mes besoins
10/02/2016 Vieux  
  France
 
Citation:
Posté par blorent Voir le message
En ce qui concerne l'intégration superviseur / CCEase il y a dans le module un switch de prévu pour donner la main soit à la CCEase (auquel cas celle-ci fonctionne et toutes les requests faites via le superviseur sont ignorées), soit au superviseur (auquel cas la CCEase est tout simplement éteinte - la connection est donc coupée directement au niveau de la VMC). Ca me semble plus simple que de chipoter avec socat, et ça marche bien pour mes besoins
Je me trompe peut être mais le but de socat et justement d'utiliser le CCEase ET le superviseur. Là tu utilises l'un ou l'autre alors autant ne pas avoir le CCEase ( c'est mon cas)
10/02/2016 Vieux  
 
  31 ans, Namur
 
En effet, c'est l'un ou l'autre. De manière générale avoir deux sources de contrôle potentiellement concurrentes ça me semble assez risqué, maintenant je n'ai pas essayé en pratique.

En ce qui me concerne le but est de remplacer mes interventions manuelles sur la CCEase (mettre sur A ou 1 la nuit suivant la température, mettre sur 2 la journée, ...) par mon superviseur, donc a priori je n'aurai plus besoin de la CCEase que pour les trucs rares comme resetter l'état des filtres (ça n'a pas l'air encore supporté dans le binding OpenHAB, mais j'ai pas encore tout lu). Je pense d'ailleurs la bouger dans le garage
10/02/2016 Vieux  
 
  56 ans, Liège
  jcoenen est connecté maintenant
Effectivement openhab et fhem gèrent la VMC mais n'autorisent pas d'autres contrôleurs (ccease,comfosense). La VMC etant accessible via l'API du gestionnaire de domotique, les clients devant être conforme à l'API. Au final chacun doit choisir le Systeme avec lequel il est le plus à l'aise. A noter que openhab peut être utilisé avec socat ET un CCease de manière déportée.
17/02/2016 Vieux  
 
  31 ans, Namur
 
Bonjour,

Petite question aux pros : j'ai constaté que régulièrement la vitesse (reportée par OpenHAB) de mon ventilateur "IN" est 5% plus élevée que le "OUT". Puis ça revient à la même vitesse.

Erreur de reporting d'OpenHAB, ou c'est la VMC qui fait ça?

Merci
19/02/2016 Vieux  
  France
 
Il me semble que c'est le cas quand la batterie antigel se met en marche. Il y a sur-ventilation: soit pour dissiper la chaleur de la résistance, soit pour déséquilibrer le IN-OUT (donc faire chuter le rendement air neuf) de façon à avoir une T extrait élevée et donc éviter la formation de glace dans l'échangeur. Je serais plutôt pour l'idée 2. Par contre j'ai pas la réponse à ça
http://www.bricozone.be/fr/showpost....postcount=1033
Mais pourquoi donc la sonde Tint de bouge pas d'un poil !!
19/02/2016 Vieux  
 
  31 ans, Namur
 
ok, merci. C'est bon à savoir, ça me permettra même de tracker quand l'antigel se met en route
Page 55 sur 67 Première page - Résultats 1 à 20 sur 1 340 Page precedente 5455354 55 565765 Page suivante Dernière page - Résultats 1 321 à 1 340 sur 1 340


A lire également sur BricoZone...
Zehnder ou Storkair / whr ou confoD ? Par chevy3600 dans Plomberie, +3 13/06/2016
Storkair ConfoD luxe et domotique Par sebcbien dans VMC, PAC, Clim, +12 21/10/2013
VMC storkair Par lombsss dans VMC, PAC, Clim, +1 25/01/2013
VMC storkair comfod 350 Par sam_bech dans VMC, PAC, Clim, +16 22/01/2013
Où acheter VMC DF Zehnder/Storkair ? Par Lapilux dans VMC, PAC, Clim, +4 26/03/2012


Forum Domotique : Voir ce forum, Nouveautés, Actifs, Sans rép
Tout BricoZone : Page de garde, Dernieres 24h

Photos au hasard
Voir toutes nos photos


Pas encore membre de BricoZone ?!
Attention Pour participer, poser une Question ou Répondre : inscrivez vous !
Ceci vous permettra également de recevoir un email lors des réponses.
Mais même si vous ne voulez rien écrire : vous pourrez surveiller les forums et leurs nouveaux messages, et obtenir une vue rapide de tous les nouveaux messages depuis votre dernière visite !
Tout ceci est évidemment gratuit et rapide.

Visitez aussi : BricoZone France, nos Blogs. On aime Astel, JardiZone et InternetVista.
 
Connexion!
Identifiant
Mot de passe

Inscription - Oublié ?

Annuaire Pro

SIBOMAT sa

Leader de la construction à ossature bois en Belgique depuis plus de 30 ans.


AlarmeMaison.biz

Pour nous la sécurité de votre maison n'est pas un vain mot.. Alarmes en KIT de bricolage!!


SUNNYHEAT by FOXeco

Chauffage infrarouge longues ondes. Le système le + économique, écologique & et sain au monde !


Eco Home sprl

Gestionnaire de projet de Construction de maisons individuelles

Ajoutez votre société