Débutant en domotique: besoin de conseils/docs...

( dans

» Electricité » Domotique

)
Chercher:    

Débutant en domotique: besoin de conseils/docs...

- Page 18
Page 18 sur 41 Première page - Résultats 1 à 20 sur 805 Page precedente 81617 18 192028 Page suivante Dernière page - Résultats 801 à 805 sur 805


17/10/2011 Vieux  
 
  39 ans, Hainaut
 
Oh la la la je vois beaucoup de truc très louche sur ces dernières 48h.

Je vais essayer de reprendre ce que j'ai vu point par point.

Pour Jean-jul. Quand tu as installé le nouveau knxweb et que tu n'avais pas les nouvelles options, c'est certainement du au cache de ton explorer (IE, chrome, FF, ..). Le mieux est de le vider quand tu installes une nouvelle version ou de faire plusieurs Refresh (F5).

Pour ce qui est des droits sur les fichiers dans le répertoire knxweb, il faut s'assurer que le user qui execute Apache à les droits en lecture sur tout les fichiers et les droits en ecriture sur le fichier /design/default/design.xml avec cela, ça doit être suffisent. Si vous voulez être sur, faites comme jphmilitaire, un chmod -r 777 sur le répertoire knxweb.

Pour le fichier linknx.xml, il n'est PAS DU TOUT NÉCESSAIRE de le copier dans le répertoire de knxweb. Je ne le recommande d'ailleurs absolument pas pour des questions de sécurité des données. Knxweb va chercher les objets de linknx en effectuant des requetes xml à linknx via un socket.

Pour l'erreur 403, jette un oeil sur google, tu devrais le résoudre rapidement.

Ton php est-il bien installé ? Peux tu créer un fichier test.php dans le répertoire /var/www avec le texte suivant dedans:

<?php
phpinfo();
?>

et dire ce que cela donne. Svp, crée ce fichier sous putty (nano test.php), pas sous windows (linux n'aime pas les fichiers windows). Donne les droits 777 à ce fichier.



Bon, aller, un peu de courage, ca va aller
17/10/2011 Vieux  
 
  32 ans, Autre pays
 
merci frédéric pour tes précieux conseils/encouragements!

mais le vrai premier probleme c'est que je ne peux plus accéder a mon pogo(en bootant sur ma clé usb...) via putty puisqu'il me met connection error avant meme de me demander le login/mdp...(et ca, je ne vois vraiment pas pourquoi!!)
en plus, je peux y accéder depuis l'explorateur (enfin juste a knxweb...)
si tu as une solution a ce pb, ca m'éaiderait bcp!! (et me permettrait d'enlever mes chauffages d'appoints!)


Ensuite, le deuxieme probleme qui en découle est celui de la connexion putty directmeent sur le pogo (sans clé usb), car le mdp n'est plus bon...et l'entreprise pogoplug bien que réactive n'arrive pas pour l'instant à résoudre le pb, car soit disant qu'ils ne trouvent pas mon pogo....
17/10/2011 Vieux  
 
  39 ans, Hainaut
 
Désolé, pour ton problème de connexion, je ne peux rien faire, je ne connais rien (pas grand chose on va dire) à linux (non, c'est vrai, je promet)
17/10/2011 Vieux  
 
  32 ans, Autre pays
 
ok!

c'est vrai que ca parait surprenant vu comment tu es calé dans les autres domaines!!

Mais pas de pb, je vais essayer de m'en demerdouiller tout seul...
Je mets juste en garde les autres utilisateurs sur le chmod 777 sur tout le repertoire /var, je reste convaincu que c'est cette manip qui m'a fait perdre la connexion via putty....

Je suis donc bon pour me refaire une install complete, en espérant que je puisse me connecter en ssh directement sur le pogo...
17/10/2011 Vieux  
 
  32 ans, Autre pays
 
bon, ben j'ai réussi a retrouver mon mot de passe root du pogo...


donc je me repastille la réinstall complete de ma clé usb...
j'ai installé pthsem, sans pb ainsi que les packages de compilation,

mais ca merdouille (!!) lors de la compil de linknx et/ou eibd....


voila ce que j'obtiens apres le ./configure de l'un ou de l'autre...

Found pthsem 2.0.8 under /usr/local, but
| was unable to perform a sanity execution check. This usually
| means that the pthsem shared library libpthsem.so is present
| but $LD_LIBRARY_PATH is incomplete to execute a Pth test.
| In this case either disable this test via --without-pth-test,
| or extend $LD_LIBRARY_PATH, or build pthsem as a static
| library only via its --disable-shared Autoconf option.
| We used the following build environment:
| CC="gcc"
| CFLAGS="-g -O2 -I/usr/local/include"
| LDFLAGS=" -L/usr/local/lib"
| LIBS=" -lpthsem"
| See config.log for possibly more details.



merci....
17/10/2011 Vieux  
 
  38 ans, Brabant Wallon
 
Citation:
Posté par jphmilitaire Voir le message
ok!

c'est vrai que ca parait surprenant vu comment tu es calé dans les autres domaines!!

Mais pas de pb, je vais essayer de m'en demerdouiller tout seul...
Je mets juste en garde les autres utilisateurs sur le chmod 777 sur tout le repertoire /var, je reste convaincu que c'est cette manip qui m'a fait perdre la connexion via putty....

Je suis donc bon pour me refaire une install complete, en espérant que je puisse me connecter en ssh directement sur le pogo...
Effectivement, je viens de regarder la doc du serveur ssh et j'ai trouvé ça:
Citation:
/var/empty
chroot(2) directory used by sshd during privilege separation in the pre-authentication phase. The directory should not contain any files and must
be owned by root and not group or world-writable.
Donc en clair, /var/empty ne peut pas avoir des droits d'accès en écriture par tout le monde. Pour corriger ça, il faudrait faire un "chmod 755 /var/empty", mais pour ça il faudrait avoir accès aux fichiers. Si tu as une autre machine linux, connecter la clé dessus permettra peut-être d'accéder aux fichiers et de régler le problème en utilisant la commande "chmod 755 /je-ne-sais-pas-trop-ou-le-contenu-de-la-clé-apparaitra-sur-le-pc/var/empty" .

Sinon, pour récupérer l'accès au pogo d'origine, as tu essayé de démarrer le pogo sans clé puis suivre la procédure d'accès sur https://my.pogoplug.com/activate/pp.html ?

Jean-François
17/10/2011 Vieux  
 
  38 ans, Brabant Wallon
 
Citation:
Posté par jphmilitaire Voir le message
bon, ben j'ai réussi a retrouver mon mot de passe root du pogo...

donc je me repastille la réinstall complete de ma clé usb...
j'ai installé pthsem, sans pb ainsi que les packages de compilation,
Bon, tu peux oublier mon message précédent alors.

Citation:
Posté par jphmilitaire Voir le message
mais ca merdouille (!!) lors de la compil de linknx et/ou eibd...

voila ce que j'obtiens apres le ./configure de l'un ou de l'autre...

Found pthsem 2.0.8 under /usr/local, but
| was unable to perform a sanity execution check. This usually
| means that the pthsem shared library libpthsem.so is present
| but $LD_LIBRARY_PATH is incomplete to execute a Pth test.
| In this case either disable this test via --without-pth-test,
| or extend $LD_LIBRARY_PATH, or build pthsem as a static
| library only via its --disable-shared Autoconf option.
| We used the following build environment:
| CC="gcc"
| CFLAGS="-g -O2 -I/usr/local/include"
| LDFLAGS=" -L/usr/local/lib"
| LIBS=" -lpthsem"
| See config.log for possibly more details.
Ca veut dire qu'a priori tu as bien installé libpthsem. Il te faut juste exécuter la commande /sbin/ldconfig (en tant qu'utilisateur root) pour qu'il mette à jour la liste des librairies installées sur le système. A chaque fois que tu installes une librairie (un fichier avec l'extension ".so", il faut exécuter cette commande. Quand tu installes des packages binaires c'est fait automatiquement, mais si tu installe un librairie avec la commande "make install" après l'avoir compilée toi même il faut le faire à la main. Je pense qu'il exécute cette commande aussi au démarrage du système, donc peut être que lors de l'install précédente un simple reboot a réglé le problème.

A+

Jean-François
17/10/2011 Vieux  
 
  32 ans, Autre pays
 
Citation:
Posté par jef2000 Voir le message
Bon, tu peux oublier mon message précédent alors.


Ca veut dire qu'a priori tu as bien installé libpthsem. Il te faut juste exécuter la commande /sbin/ldconfig (en tant qu'utilisateur root) pour qu'il mette à jour la liste des librairies installées sur le système. A chaque fois que tu installes une librairie (un fichier avec l'extension ".so", il faut exécuter cette commande. Quand tu installes des packages binaires c'est fait automatiquement, mais si tu installe un librairie avec la commande "make install" après l'avoir compilée toi même il faut le faire à la main. Je pense qu'il exécute cette commande aussi au démarrage du système, donc peut être que lors de l'install précédente un simple reboot a réglé le problème.

A+

Jean-François
Salut J-F!

quel bonheur de te lire! tout est si clair!

ok pour les droits de ssh...je m'en doutais, mais comme je ne savais pas quel repertoire devait avoir quel droit, ben j'ai tout réinstallé...(ce qui résoudra peut etre mon pb de knxweb!)

va pour la commande "/sbin/ldconfig", je teste de suite!

et oui, la premiere fois, j'avais du le redémarrer....

heureusement que j'ai sauvé la derniere version de mon linknx.xml....
18/10/2011 Vieux  
 
  32 ans, Autre pays
 
bon, je crois avoir réussi a tout installer...

mais quand je lance (apres avoir rebooté!)
bcuaddrtab -w0 usb: pour initialiser les tables de l'interface, j'obtiens direct:initialisation failed


eibd -S -T -i -e 127.0.0.1 -t65535 usb: me donne une belle erreur alacon style eibd: invalid option -- 'S'
en fait, je me demande si eibd est bien installé....?

a suivre, mais la dodo, suis hs!
18/10/2011 Vieux  
  39 ans, Hainaut
 
ca fait peur, je viens de commander mes actuateurs et 5 interrupteurs (+ alim, + interface USB)...

On verra vendredi... J'ai un doute sur la prise en charge de l'interface USB que j'ai acheté (c'est celle de eibmarkt --> http://www.eibmarkt.com/cgi-bin/eibm...ID=EN_N000403), je sais pas, je le sens pas, je sais que EIBD ne va pas être compatible.... Bouhouhou, vivement vendredi !!! Et je vous rejoins dans le club des bidouilleurs, mon pogo n'attend que çà...

Ceci dit : première connerie, j'ai acheté le pogo PRO qui ne supporte pas Debian, me voila déjà en ArchLinux, mais ca tourne au moins ;)
18/10/2011 Vieux  
 
  32 ans, Autre pays
 
ah oui, t'es joueur avec ton interface toi!!

perso, j'ai pris ABB, au moins, ca marche (enfin ca devait aprcequ'il faut que je lance une ligne de commande juste avant de lancer eibd pour purger la table d'adresse du bidulle....)

le pogo pro?? connais pas...

tu as pu activer ssh dessus?? la case apparaissait depuis le site my.pogo??

a+ sur ce topic!
18/10/2011 Vieux  
  39 ans, Hainaut
 
ouais, pas de problème, j'en ai fais un serveur DLNA en attendant, mais c'est pas top... Je dois essayer miniDLNA qui est surement mieux que uShare...

J'ai vu que t'étais allergique à Linux (en début de thread), pour ma part, c'est une histoire d'amour depuis le départ, mais j'avoue ne pas encore tout saisir, mais je me sens assez à l'aise pour installer EIBD et le reste...
18/10/2011 Vieux  
  46 ans, Hainaut
 
le pogo pro c'est le pogo + wifi non ?
18/10/2011 Vieux  
 
  32 ans, Autre pays
 
bon, ca y est, j'ai tout réinstallé (sauf knxweb, mais je l'aime pas encore lui! )

tout remarche bien, (meme linknx!), mais quand je tape en ligne de commande un truc du style:
grouplisten ip:127.0.0.1 1/1/4

et ben j'obtiens ca:
grouplisten: error while loading shared libraries: libeibclient.so.0: cannot open shared object file: No such file or directory
root@debian:~#


idem pour groupread, groupswrite...

vous savez pourquoi???

a coté de ca, linknx recoit et envoie ses ordres sans pb....
18/10/2011 Vieux  
 
  38 ans, Brabant Wallon
 
Citation:
Posté par Scanx_Taz Voir le message
Ceci dit : première connerie, j'ai acheté le pogo PRO qui ne supporte pas Debian, me voila déjà en ArchLinux, mais ca tourne au moins ;)
Je suis également parti sur ArchLinux. La doc d'installation sur le site http://archlinuxarm.org/platforms me paraissait plus claire que celle pour Debian.
J'ai compilé quelques packages pour le pogo (je ne sais pas si c'est compatible avec le pogo pro, mais j'ai mis également les fichiers PKGBUILD qui permettent de recompiler plus facilement et avec les options dont on a besoin)

http://ouaye.net/linknx/pogo-archlinux/

J'essaierai de faire un tuto un de ces jours.
19/10/2011 Vieux  
  39 ans, Hainaut
 
Jef,

Un grand merci ! ET superbe travail, vraiment ! Je suis en admiration ;)
Ca doit être fou de se dire que le programme qu'on a inventé sera dans des centaines de maison !

On peut rajouter un petit code pour avoir accès à toutes les webcams de toutes ces maisons ? On sait jamais ;) ;) ;)
19/10/2011 Vieux  
 
  32 ans, Autre pays
 
Citation:
Posté par jphmilitaire Voir le message
bon, je crois avoir réussi a tout installer...

mais quand je lance (apres avoir rebooté!)
bcuaddrtab -w0 usb: pour initialiser les tables de l'interface, j'obtiens direct:initialisation failed


eibd -S -T -i -e 127.0.0.1 -t65535 usb: me donne une belle erreur alacon style eibd: invalid option -- 'S'
en fait, je me demande si eibd est bien installé....?
Bon, en fait linknx merdouille aussi: la pac est tout le temps allumé!! mais il a quand meme envoyé l'ordre de s'allumer, donc ca communiuqe "un peu"...

si quelqu'un a une piste....

je vais essayer de creuser ca ce soir, mais je sens bien que tout seul c'est pas gagné...
19/10/2011 Vieux  
  39 ans, Hainaut
 
Tiens, j'ai téléchargé les packages pour ArchLinux, et tout est installé, me manque plus que les composants KNX...

Cependant, pour préparer le terrain, j'ai fait quelques tests, et je vois que je n'ai pas "findknxusb"...
Le package pour Arch est complet ???
19/10/2011 Vieux  
  39 ans, Hainaut
 
Citation:
Posté par boubanstik Voir le message
le pogo pro c'est le pogo + wifi non ?
oui, c'est le pogo avec Wifi, je trouvais çà pas mal, mais après réflexion, si j'avais su, j'aurais pris le pink tout simple, qui a plus de ram...
19/10/2011 Vieux  
 
  32 ans, Autre pays
 
findknxusb doit faire partie de eibd, je suppose...

je savais pas que le pogo avec wifi était plus chiant a configurer et avait moins de ram...en plus, j'avais hésité à l'acheter à l'époque...
Page 18 sur 41 Première page - Résultats 1 à 20 sur 805 Page precedente 81617 18 192028 Page suivante Dernière page - Résultats 801 à 805 sur 805


A lire également sur BricoZone...
Domotique, nouvelle construction : vos conseils ? Par sro_sro dans Domotique, +12 30/09/2010
petite surface à bétonner, conseils pour débutant. Par Qat dans Maconnerie, Chape, +1 11/07/2009
Besoin d'aide - Instal. domotique Par Blazebebe dans Domotique, +16 30/05/2009
Besoin d'info : Schema unifilaire domotique Par Mikeadero dans Domotique, +18 16/04/2009
Besoin de conseils Par nat2211 dans Construction, +37 02/10/2008


Forum Domotique : Voir ce forum, Nouveautés, Actifs, Sans rép
Tout BricoZone : Page de garde, Dernieres 24h

Photos au hasard
Voir toutes nos photos


Pas encore membre de BricoZone ?!
Attention Pour participer, poser une Question ou Répondre : inscrivez vous !
Ceci vous permettra également de recevoir un email lors des réponses.
Mais même si vous ne voulez rien écrire : vous pourrez surveiller les forums et leurs nouveaux messages, et obtenir une vue rapide de tous les nouveaux messages depuis votre dernière visite !
Tout ceci est évidemment gratuit et rapide.

Visitez aussi : BricoZone France, nos Blogs. On aime Astel, JardiZone et InternetVista.
 
Connexion!
Identifiant
Mot de passe

Inscription - Oublié ?

Annuaire Pro

SIBOMAT sa

Leader de la construction à ossature bois en Belgique depuis plus de 30 ans.


AlarmeMaison.biz

Pour nous la sécurité de votre maison n'est pas un vain mot.. Alarmes en KIT de bricolage!!


SUNNYHEAT by FOXeco

Chauffage infrarouge longues ondes. Le système le + économique, écologique & et sain au monde !


Eco Home sprl

Gestionnaire de projet de Construction de maisons individuelles

Ajoutez votre société