comment avoir l'heure sur le bus knx ?

Dans le forum Domotique - par Hiboux le 30 Novembre 2019

  1. Hiboux

    Hiboux 39 ans, Hainaut

    salut ,

    Vous avez fait quoi pour obtenir l'heure sur votre bus ?
     
    Hiboux , 30 Novembre 2019
    #1
  2. eljub

    eljub 37 ans, Brabant Wallon

    j'ai une station météo qui se synchronise en gps
     
    eljub , 30 Novembre 2019
    #2
  3. ronald7760

    ronald7760 44 ans, Hainaut

    salut.

    j'ai une tablette Zennio qui est synchronisée sur le net.
     
    ronald7760 , 30 Novembre 2019
    #3
  4. Hiboux

    Hiboux 39 ans, Hainaut

    Merci déjà de vos réponses , il y a pas un moyen plus simple de l obtenir ?
     
    Hiboux , 30 Novembre 2019
    #4
  5. eljub

    eljub 37 ans, Brabant Wallon

    eljub , 30 Novembre 2019
    #5
  6. jcoenen

    jcoenen 60 ans, Liège

    j'ai un raspberry raccordé via ethernet (IP) à un gateway knx (ou via interface usb) et je met l'heure via knxd et groupswrite sur une adresse de groupe.
     
    jcoenen , 5 Décembre 2019
    #6
    Sysun et eljub aiment ça.
  7. Sysun

    Sysun 42 ans, Hainaut

    j'ai également un Raspberry avec jeedom et gateway KNX idem...
     
    Sysun , 5 Décembre 2019
    #7
  8. Hiboux

    Hiboux 39 ans, Hainaut

    Merci les gars , je vais regarder ça quand je serai sur mon pc , je pensais pas que avoir l heure était si compliqué :joy:
     
    Hiboux , 5 Décembre 2019
    #8
  9. Hiboux

    Hiboux 39 ans, Hainaut

    Petite question knx .

    Ici j'ai commencé a programmer un interrupteur mtd 2x (hier ) pour allumer ma buanderie .J'ai galéré mais au finale j'ai réussi . Je l'ai mis en adresse de groupe les 2 boutons switch tout les deux en mode inverser + l'objet statut "toggle" + la sortie de mon abb correspondante et l'objet "commutation de l’état ". tout fonctionnait .

    Aujourd'hui je m'attaque à plus gros , un écran mtd , je paramètre les dessins , les titres ect .
    ensuite je crée un bouton pour les spots de ma chambre et une fonction all off sur une adresse de groupe et une fonction en appuis long (deuxièmes objets) en "on" qui active la lampe de sdb , de la cuisine et du salon pour quand je me lève au matin ( c'est plutôt un test pour découvrir les fonctions) .
    tout fonctionne ok aussi .

    à savoir que il y a quelque moi , j'ai mit des abb us dans des interrupteurs niko de façon provisoire pour ne pas aller chaque fois dans la boite a fusible . sur un de c'est abb dans le couloirs du haut j'ai mit une fonction all off qui fonctionne bien depuis min 6 mois .

    donc si vous me suivez toujours voila mon problème .

    tout content d'avoir compris et programmer le bazar je vais dans ma buanderie , j'allume et ce chacal d'interrupteur me fait du all/ on /off .
    alors qu'il n'est pas programmer pour ça .
    je chercher et je bug complètement , j'ai regardé les adresse de groupe tout est correcte ...
    ici je vais réinitialiser l’interrupteur et le recharger car je ne vois pas d'ou cela viens , si li y a un conflit etc...

    si vous avez déjà eu ça ?
     
    Hiboux , 8 Décembre 2019
    #9
  10. jcoenen

    jcoenen 60 ans, Liège

    Non, à part quand merdouillage dans les assignation, mais ça a toujours été de ma faute ...

    il y avait toujours une explication rationnelle à la chose.
     
    jcoenen , 8 Décembre 2019
    #10
    Hiboux aime ça.
  11. Hiboux

    Hiboux 39 ans, Hainaut

    bon j'ai pas réussi a voir d'ou le problème venait , j'ai déchargé le participant et effacer l'adresse de groupe mais rien .
    Quand je la reformais , le problème revenait .
    j'ai créé la même fonction sur un abb us , pas de soucis , je ne sais pas si il y a conflit entre les deux mdt , l’interrupteur enverrais des commande qui serai prise pour l’écran (ça me paraîtrait gros quand même ) .
    en plus il n'y a pas bcp d'option sur le 2x.... et ça le faisait encore une fois que j'ai effacé l'adresse "all on" de l écran.
    . je suis trop fatigué aujourd'hui , je continuerai demain , je finirai par trouver
     
    Hiboux , 8 Décembre 2019
    #11
  12. jcoenen

    jcoenen 60 ans, Liège

    peut être que regarder les messages qui passent sur le bus quand on pousse sur l’interrupteur aiderait, voir sur ETS la fenêtre monitoring ...
     
    jcoenen , 8 Décembre 2019
    #12
    Sysun aime ça.
  13. Hiboux

    Hiboux 39 ans, Hainaut

    Je pense que soit ,ça n a pas charger correctement . Soit ça viens peut être d une valeur d état qui repart vers l interrupteur écran quand on active l actuateur abb et alors active le all off ou on . Ce qui est bizarre c est que j ai programmé le all off pour toutes ces lampes mais elles ne sont pas toutes dans le all on . Donc ça inverse la commande all off qui en Plus ne se trouve pas dans l adresse de l interrupteur concerné...
     
    Hiboux , 9 Décembre 2019
    #13
  14. jcoenen

    jcoenen 60 ans, Liège

    Soit la configuration n'a pas été téléchargée (mais alors le download serait signalé incomplet par ETS ?) soit il y a une raison au niveau des groupes (j'ai déjà vu des comportements bizarres quand on met un état dans un groupes de commande pour piloter un interrupteur en mode "toggle").

    Par contre pourquoi le all On/Off est il activé si celui ci n'est pas lié dans un groupe a cet état, là, mystère.

    Ce serait bien d'avoir la configuration des groupes avec les variables assignées, sans ça on est un peu dans le brouillard ...
     
    jcoenen , 9 Décembre 2019
    #14
  15. Hiboux

    Hiboux 39 ans, Hainaut

    Je ferai des print screen quand je serai chez moi merci
     
    Hiboux , 9 Décembre 2019
    #15
    Sysun et jcoenen aiment ça.
  16. Hiboux

    Hiboux 39 ans, Hainaut

    bon voila , j'ai regardé un peu
    en gros j' avais supprimé l'adresse de groupe et je l'ai recrée et maintenant cela marche , je comprend pas pourquoi car j'avais fait le même la dernière fois .
    J'ai recréer la fonction all off aussi que j'avais également supprimer .
    je met quand meme les prints
    2019-12-11 (1).png 2019-12-11.png

    la seul valeur que j'ai modifiée et je pense avoir essayé aussi la derniére fois , c'est "no read value for toggle" .
    je ne sais pas si ça peux provoquer ce que j'ai eu .
    J'aurai aimé comprendre pour progresser ;-)
     
    Hiboux , 12 Décembre 2019
    #16
  17. jcoenen

    jcoenen 60 ans, Liège

    Curieux si tout est remis dans l'état précédent.
    Au fait dans le général, les sorties sont avec deux paramètres.

    1) Commutation (OK c'est le On/Off)
    2) Commutation de l'état (???? quel est la fonction de ce paramètre ?)

    D'habitude pour le all off, je met dans le groupe les Sorties à piloter et la commande de l'interrupteur qui n'envoit que OFF. Alors je ne comprend pas trop la raison du deuxième paramètre.

    Le no read value for toggle (d'après le titre) ne tient pas compte de l'entrée d'état pour déterminer le signal a envoyer.

    Donc dans un groupe "toggle" il y a:

    Groupe Toggle
    1) l'indicateur d'état du relais de l'actionneur.
    2) entrée de l'interrupteur toggle 1
    3) entrée interrupteur toggle 2
    ...

    Groupe commande lampe
    1) sortie interrupteur 1
    2) sortie interrupteur 2
    3) entrée actionneur (pilote du relais)

    La sortie de l'interrupteur est donc le résultat de la valeur fournie par l'indicateur d'état de l'actionneur, cela permet de piloter un relais a partir de plusieur interrupteurs toggle

    Certain actionneurs autorisent à mettre tout ça dans un seul groupe (Hager par ex.) mais ce n'est pas le cas chez tout les fabricants et cela peut poser des problèmes de commutation.

    Attention que dans l'usage du toggle il faut bien entendu faire gaffe et limiter tant que faire se peut à un seul relais.

    Imaginons deux relais qui donnent deux valeur d'état, l'un peut être ON et l'autre OFF, quel commande doit alors être envoyée ???
     
    Dernière édition: 12 Décembre 2019
    jcoenen , 12 Décembre 2019
    #17
  18. Hiboux

    Hiboux 39 ans, Hainaut

    Commutation de l état permet de donner la valeur de l état de la sortie. Au début je ne l avais pas mit et pour un va et viens . Je devais appuyer deux fois pour éteindre une lampe allumée par un autre interrupteur.
    Pour le all off je l ai mit sans trop tester à vrai dire en me
    Disant que le principe était le même que si toutes les lampes étaient éteintes par le all off . Quand je les rallumerai avec un autre interrupteur, il ne serai peut être pas au fait de l état de la sortie , donc je ´ ai mit peut être par erreur .

    Je ne comprend pas le dernier exemple que tu donnes , désolé je suis novice .
    Pour moi si il y a deux relais dans un groupe toggle. Si il est sur on et l autre sur off . Ne vont t il pas s’inverser chaqu un tout simplement ? Après je pense qu à la base il doivent être mit chaqu un dans le même état si ils sont destinés à être pilotés ensembles .
    Mais j imagine là difficultés si c est pour piloter une zone de 9 spots par exemple pour le salon . Commandée par deux interrupteur avec la fonction toggle sur les trois relais mais que en parallèle il y a une adresse de groupe pour piloter et donc éteindre les spots relais par relais .
    On pourrait donc se retrouver avec 3 spots allumés et 6 éteint. Et quand on activerai la fonction toggle, 6 s allumererait et 3 seraient éteints.
    J avoue que n ai pas encore été si loin , donc pour moi je suis dans la théorie un peu vague . J imagine qu il doit avoir moyen de programmer ça par une fonction logique du genre si x min se sont écoulées inverser l état sur off . ( pure spéculation )
     
    Hiboux , 12 Décembre 2019
    #18
  19. jcoenen

    jcoenen 60 ans, Liège

    En fait tout dépend des applications sur les participants et qui de l'actionneur ou de l'interrupteur implémente la fonction toggle.

    Dans ton exemple, si l'actionneur implemente le toggle alors pas de problème, il reçoit une commande "toggle" et il inverse sa sortie, dans ce cas là c'est tout simple, mais je n'ai jamais vu cela implémenté (ce qui ne veut pas dire que ca n'existe pas).

    Les commandes KNX de relais étant codées sur 1 bit c'est ON (1) ou OFF (0), l'implémentation d'un toggle a partir de l'acionneur demanderait un codage sur 2 bits (donc sur un dpt.2).

    Dans l'autre cas, c'est l'interrupteur qui implémente le toggle comme suit:

    Il reçoit de l'acionneur une infomation d'état qui indique l'état de la sortie.
    Si la sortie est ON alors un appui envoit OFF (cmd bit à 0)
    Si la sortie est OFF alors un appui envoit ON (cmd bit à 1)

    Et donc dans ce cas de figure, l'indicateur d'état de la sortie est le facteur important, si dans le groupe il y a plusieurs indicateurs d'état, l'interrupteur enverra la commande inverse du dernier état reçu par le goupe.


    Pour piloter un groupe de lampes avec possibilité de piloter isolément des sous groupes demande alors d'encoder logiquement les différentes possibilités (via un module de logique) recherchées au départ des interrupteurs de commande.
     
    jcoenen , 12 Décembre 2019
    #19
  20. petithomme76

    petithomme76 43 ans, Liège

    il y aurait pas un beau tutorial sur knx et jeedom ?
    uniquement eth pas usb possible ?
     
    petithomme76 , 12 Décembre 2019
    #20
Chargement...

Sujet similaires

Vous pouvez aussi lancer une recherche sur : heure bus knx

Similar Threads - heure bus knx
  1. inuites

    Compteur impulsion KNX

    inuites, +1 (filou59), 4 Janvier 2020
    1
    Affichages:
    131
    filou59
    4 Janvier 2020
  2. jeffou80

    Bus KNX sur 5G1.5

    jeffou80, +4 (moustic999), 22 Mars 2016
    4
    Affichages:
    1 057
    moustic999
    22 Mars 2016
  3. pascal 7134

    adaptateur BUS --> filaire

    pascal 7134, +1 (eljub), 7 Avril 2014
    1
    Affichages:
    835
    eljub
    7 Avril 2014
  4. seb537

    cable bus trop court

    seb537, +3 (remyb), 27 Février 2014
    3
    Affichages:
    924
    remyb
    10 Avril 2014
  5. Fred1979

    lire les données du bus

    Fred1979, +9 (Fred1979), 8 Décembre 2013
    9
    Affichages:
    1 418
    Fred1979
    17 Décembre 2013
  6. jipsie

    ETS : Could not connect to the bus

    jipsie, +2 (jipsie), 6 Mai 2013
    2
    Affichages:
    1 451
    jipsie
    6 Mai 2013
  7. srn

    module LOGO! et BUS

    srn, +4 (srn), 3 Octobre 2012
    4
    Affichages:
    1 694
    srn
    30 Octobre 2012