Configuration Alarme Kyo via cable série sous XP

Dans le forum Alarme - par fab94 le 10 Avril 2010

  1. fab94

    fab94 44 ans, France

    Bonjour à tous,

    J'essaie de configurer mno alarme Kyo8 avec un PC.
    J'ai connecté un cable USB/série.
    J'ai installé les drivers. J'utilise le port com4 come indiqué dans le gestionnaire de périphérique.
    J'ai récupéré le logiciel sur le site de Bentel et j'ai paramétré une configuration.

    Le problème est que lorsque je l'envoie à la centrale via le cable DB9, j'ai un mesage d'erreur : Erreur de lecture adresse ($0000)

    Quelqu'un peut-il m'aider ?

    Est-ce que la centrale peut être configurée avec un câble standard ou est-ce que le câble Bentel est spécifique ?

    Merci de votre aide.

    Fabrice
     
    fab94 , 10 Avril 2010
    #1
  2. danlolo

    danlolo 48 ans, Luxembourg

    Bonjour,

    le câble est tout à fait standard RS232.

    il faut juste bien vérifier que le centrale n'est pas en mode installateur, mais bien en mode utilisateur pour pouvoir programmer via le pc.

    Bonne journée.

    Dan.
     
    danlolo , 11 Avril 2010
    #2
  3. fab94

    fab94 44 ans, France

    Bonjour Dan,

    Merci pour ta réponse.

    J'ai un clavier Premium LCD, qui est actif et connecté à la centrale.
    De ce que je comprends le mode installateur c'est quand on tape le code installateur + entrée, et le mode utilisateur c'est quand on sort de ce mode via la touche esc.

    Est-ce que j'ai raté quelque chose ?
    Si c'est bien celà, alors je suis bien en mode utilisateur.

    Par ailleurs en consultant le manuel d'installation, j'ai vu que sur le schéma en page 77 il y a un croisement entre les broches 2 et 3. Ce qui me ramène à ma question d'origine, "le câble de Bentel est-il spécifique ou n'importe quel câble série peut faire l'affaire ?";(
     
    fab94 , 11 Avril 2010
    #3
  4. pcouv

    pcouv 51 ans, Hainaut

    le mode utilisateur est ton code utilisateur et enter tu peux ainsi programmer tes codes et tes téléphones ainsi que remettre l'heure et la date à jour ainsi que d'autres petites choses.
    N'importe quel cable série est valable, la preuve est que le programme t'a indiqué erreur de lecture.
    Donnes nous l'adresse ou tu as téléchargé le programme car pour nous installateur il est livré avec un toggle et nous coute 500€ brut pour l'achat des versions upgradées.
     
    pcouv , 11 Avril 2010
    #4
  5. fab94

    fab94 44 ans, France

    J'ai donc un autre problème ...

    Dans le manuel de programmation par clavier, j'ai trouvé comment paramétrer les différents codes depuis le clavier, mais pas comment saisir les codes.

    Si quelqu'un peut m'expliquer coment saisir le code et passer en mode utilisateur ?? Merci d'avance.

    Pour ce qui est du câble, je l'ai acheté chez Abix. Il est de la marque Dacomex.
    Je suis donc allé sur le site de Dacomex. L'url est : http://www.dacomex.fr/adaptateur-usb-1-1-a-serie-pdt-33-58-22.html

    Après installation, j'ai vérifié dans le gestionnaire de périphérique et tout est correct. Il utilise le port com 4.
     
    fab94 , 11 Avril 2010
    #5
  6. fab94

    fab94 44 ans, France

    En cherchant sur le net, j'ai trouvé que les codes utilisateurs sont de 0001 à 0024.
    J'ai donc saisi le code 0001 + entrée sur le clavier et je suis donc entré en mode utilisateur.
    J'ai connecté mon PC sur la centrale via le cable et j'ai essayé de nouveau de transmettre la config.
    J'ai toujours le même message d'erreur : ereur de lecture Adresse ($0000)

    Quelqu'un a-t-il une solution ?
    Merci
     
    fab94 , 11 Avril 2010
    #6
  7. danlolo

    danlolo 48 ans, Luxembourg

    le câble que tu utilise entre le convertisseur USB-RS232 et le centrale doit être un câble croisé en effet.
    si tu as §0000, ton port est bien ouvert, mais est il bien configurer dans le soft : parametre: port serie: centrale: port 4. c'est peut etre une bete question, mais le port 1 ( par défaut peut parfois etre déja utilisé).

    pour saisir un nouveau code: tape ton code maitre (0001 usine) + enter; 10 x d pour naviguer dans le menu jusqu'a program code, "enter" et le tu peux introduire le nouveau code. si tu veux, tu m'envoie ton mail et je t'envoie la notice utilisateur.
     
    danlolo , 11 Avril 2010
    #7
  8. Miotom

    Miotom 67 ans, Liège

    Bonjour.

    A tout hasard ton câble DB9 qui sort de ton port série PC et qui va a la centrale est bien nul modem

    Il s'agit d'un câble inverseur, mettant en relation les broches d'émission et de réception des ports série de chaque appareil.

    PC bornes..................CENTRALE bornes

    Rx 2 .............................. Tx 3
    Tx 3 .............................. Rx 2
    DTR 4 ............................ DSR + CD 6 + 1
    GND 5 ........................... GND 5
    DSR + CD 6 + 1 ................DTR 4

    RS 7 .............................. CS 8
    CS 8 ............................. RS 7
     
    Miotom , 11 Avril 2010
    #8
  9. Miotom

    Miotom 67 ans, Liège

    Ok pour moi, le port est bien ouvert puisqu'il lit une erreur sur l'adresse $ 0000
     
    Miotom , 11 Avril 2010
    #9
  10. dans le 1er post il dit employer un convertisseur USB/série...
     
    benoki , 11 Avril 2010
    #10
  11. Miotom

    Miotom 67 ans, Liège

    :grinning: Mea culpa 20 X :grinning:
     
    Miotom , 11 Avril 2010
    #11
  12. de rien ;)
    en fait mon avis est qu'il ne lit rien de rien, c'est le programme qui est mal ***** et au lieu de donner une erreur d'ouverture de ligne , il tente directement de lire la première adresse mémoire ($0000) , et évidement ca bloque..

    et en essayant d'ouvrir un autre équipement série ? ou tenter d'ouvrir le COM4 avec hyperterminal et connecté à la centrale ? ca donne quoi ?
     
    benoki , 11 Avril 2010
    #12
  13. danlolo

    danlolo 48 ans, Luxembourg

    [​IMG]


    voici le câblage à réaliser issu de la notice bentel
     
    Dernière édition par un modérateur: 11 Avril 2010
    danlolo , 11 Avril 2010
    #13
  14. fab94

    fab94 44 ans, France

    J'ai testé tous les ports com.
    Les seuls ouverts sont 4 et 5.

    La fiche technique du câble indique :
    Avec l’adaptateur USB 1.1 à série DACOMEX, reliez facilement tous vos périphériques série (DB9 ou DB25) sur un port USB. Installez les pilotes fournis et créez votre port COM virtuel sur votre PC.
    Conforme à la Norme EIA-S232 (de ce que je comprends il s'agit de la norme RS232).

    Ce qui m'inquiète c'est qu'il n'est pas fait mention de null modem sur le descriptif du constructeur.
     
    fab94 , 11 Avril 2010
    #14
  15. fab94

    fab94 44 ans, France

    est-ce que je dois croiser les fils 2 et 3 pour que ça fonctionne ?
     
    fab94 , 11 Avril 2010
    #15
  16. danlolo

    danlolo 48 ans, Luxembourg

    2 et 3 doivent absoloment etre croisés oui sinon cela ne marche pas du tout
     
    danlolo , 11 Avril 2010
    #16
  17. Miotom

    Miotom 67 ans, Liège

    Affirmatif Benoki son pc ne voit rien.

    Essaye puisque Danlolo, te procure le plan et la topo des connexions au post 8.
    :heart_eyes:
     
    Miotom , 11 Avril 2010
    #17
  18. Miotom

    Miotom 67 ans, Liège

    C'est que ton câble DB9 n'est pas nul modem si cela devait être le cas le constructeur le mentionnerait aussi dans son descriptif "normalement".
     
    Miotom , 11 Avril 2010
    #18
  19. c'est que le driver du machin ne fourni pas toutes les fonctions normalement disponibles pour un COM1/2 hardware, et en lisant la doc ils spécifient USB 1.1 ET 480Mb/s. donc j'ai franchement des doutes...

    le programme lui doit se baser sur les "vrais" COM3/4.

    un vrai convertisseur avec UART coute +que 150 eur.
     
    benoki , 11 Avril 2010
    #19
  20. fab94

    fab94 44 ans, France

    J'ai connecté les 2 DB9 avec des fils en wrappant.
    Ca a marché du premier coup.

    Mon premier problème est donc résolu.
    Merci pour votre aide à tous

    Mon second problème est le suivant :
    J'ai 2 sirènes SI-Box que je souhaite connecter à la centrale.
    Dans chacune des sirène il y a un accu.
    Le problème est que dès que je branche les fils, ça gueule !

    Quelqu'un peut-il me dire les étapes pas à pas ?
    Merci
     
    fab94 , 11 Avril 2010
    #20
Chargement...

Sujet similaires

Vous pouvez aussi lancer une recherche sur : Configuration Alarme Kyo

Similar Threads - Configuration Alarme Kyo
  1. humbucker

    Configuration Lightsys 2

    humbucker, +1 (actechnique), 28 Août 2016
    1
    Affichages:
    599
    actechnique
    28 Août 2016
  2. fafalili

    configuration bbox3 pour camera IP

    fafalili, +14 (petithom), 27 Août 2015
    14
    Affichages:
    4 335
    petithom
    28 Août 2015
  3. didoo123

    Coment configurer les adresses de 2 claviers?

    didoo123, +4 (didoo123), 18 Décembre 2013
    4
    Affichages:
    612
    didoo123
    23 Décembre 2013
  4. bdeschryver

    Configurateurs système bticino

    bdeschryver, +5 (freddo), 26 Octobre 2012
    5
    Affichages:
    1 671
    freddo
    13 Novembre 2012
  5. Masadido

    Kyo32G : Comment "bien" configurer la fonction panique

    Masadido, +6 (pcouv), 4 Janvier 2012
    6
    Affichages:
    1 709
    pcouv
    17 Septembre 2012
  6. fab94
    1
    Affichages:
    3 579
    davidisa
    7 Mai 2011
  7. ced09

    configuration alamre

    ced09, +14 (pcouv), 4 Février 2009
    14
    Affichages:
    2 765
    pcouv
    19 Mars 2009